anonymous
  • anonymous
I currently have Python v2.7.3. Is that compatible with the course materials used for this session? If not, what is the next step to download v2.6.8 from here: http://www.python.org/download/releases/2.6.8/? Thanks in advance!
MIT 6.189 A Gentle Introduction to Programming Using Python (OCW)
  • Stacey Warren - Expert brainly.com
Hey! We 've verified this expert answer for you, click below to unlock the details :)
SOLVED
At vero eos et accusamus et iusto odio dignissimos ducimus qui blanditiis praesentium voluptatum deleniti atque corrupti quos dolores et quas molestias excepturi sint occaecati cupiditate non provident, similique sunt in culpa qui officia deserunt mollitia animi, id est laborum et dolorum fuga. Et harum quidem rerum facilis est et expedita distinctio. Nam libero tempore, cum soluta nobis est eligendi optio cumque nihil impedit quo minus id quod maxime placeat facere possimus, omnis voluptas assumenda est, omnis dolor repellendus. Itaque earum rerum hic tenetur a sapiente delectus, ut aut reiciendis voluptatibus maiores alias consequatur aut perferendis doloribus asperiores repellat.
chestercat
  • chestercat
I got my questions answered at brainly.com in under 10 minutes. Go to brainly.com now for free help!
anonymous
  • anonymous
I am into this question too
anonymous
  • anonymous
You need to install 2.6.x version it is stated on this website, check the note on the top of the table http://ocw.mit.edu/courses/electrical-engineering-and-computer-science/6-189-a-gentle-introduction-to-programming-using-python-january-iap-2011/assignments/
anonymous
  • anonymous
There are no issues running two versions?

Looking for something else?

Not the answer you are looking for? Search for more explanations.

More answers

anonymous
  • anonymous
According to this is possible http://stackoverflow.com/questions/4583367/how-to-run-multiple-python-version-on-windows and there is similar article if you are using linux so it should be ok.
anonymous
  • anonymous
I tried to find the Windows Installer for 2.6.8 on the Python site, but it was not listed in the downloads, so I installed 2.6.6, which had the installer link. As far as my question about different version, I found out you just need to make sure the path in the code is going to the correct version of Python that you want, so two versions is okay.
anonymous
  • anonymous
All 2.X versions are compatible with each other. Therefore, you have no need to install multiple versions or replace your existing one, just install the latest and greatest and update. As long as you don't go for a 3.X version, you'll be safe and happy! Good luck!
anonymous
  • anonymous
what about the latest version of jython? would that be ok?
anonymous
  • anonymous
@gonzo0481 Don't get smart with me! Jython's FAQ says it is compatible with Python code BEFORE 2.3. Any features added on afterwards will be missing though. So no, it wouldn't be safe to use in any academic course using 2.3+.
anonymous
  • anonymous
ok thanks.
anonymous
  • anonymous
will there be any compatibility issues if i have jython 2.5.3 and python 2.7.3 installed?
anonymous
  • anonymous
Not at al!

Looking for something else?

Not the answer you are looking for? Search for more explanations.